Reaching out to the kinja gods for some help or possible causes of a problem. I'm running the most recent version of Firefox on Windows 7 and a separate Windows 8 laptop. Once, maybe twice, in the past, I've come across a problem where I'm suddenly logged out of kinja (I'm mainly on Gizmodo & Whitenoise) without realizing it until I go to a new page or refresh the one I'm on. When I try to log in again (with the same Google acct. I've used on here for several years) it does nothing. No matter how many times I try to log in, it continues to say "Log In/Sign Up" at the top of the page.

Troubleshooting steps: I've tried clearing my cache & cookies. I've restarted FF in Safe Mode (all add-ons disabled) to see if it was a rogue add-on causing the problem. I've deleted several files from my FF profile folder that didn't pertain to my add-ons thinking one of them was corrupted. The only solution I've found is to completely delete that FF profile and create a new one. Once done, I can log in to kinja just fine.

This has happened on both my Windows 7 and Windows 8 machines. Now after not having experienced this in quite a long time, in the last couple weeks, it has happened three times. Any ideas? Sounds like something is being saved within my FF profile that causes this and once it's deleted, the problem goes away, but sometimes only temporarily. I don't experience this anywhere else on the net. I haven't found anyone else having this problem so one might think it's my devices, but on two separate devices...what are the odds?